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THE 351-STEP, ULTIMATE DIY, PUBLISH-YOUR-

OWN-BOOK CHECKLIST 

 

Everything You Need to Do to Become a Published Author and Recognized 

Thought Leader in Your Niche—AND How To Get Your Book To Sell on Autopilot! 

 

After creating professionally designed books for over a dozen years and for thousands of 
authors, we have streamlined the process to these 351 steps. If you follow each of these steps, 
you will have a professionally designed book that literally sells on autopilot. 

But if you’re like most of my authors, you’re starved for time and would like this all done for 
you. After all, this is a pretty intimidating list! 

We offer a complimentary 15-minute phone call to determine the absolute best path for you to 
take on your way to becoming a published author. 

If you’d like to bypass these 351 steps, skip to the end of the checklist to learn how you can 
save 10% today. 

 



 

 

Your Simple 351-Step Process to Design and Publish Your Book 

The following checklist assumes that you’re starting with an edited manuscript. If you want to edit your 
own book, this checklist will increase in length significantly. 
 

PRINT INTERIOR LAYOUT 
 

1. Clean up the manuscript in MS Word (remove double-spaces, extra lines, etc.) 
2. Pre-format the manuscript to prepare for importing into Adobe InDesign 
3. Determine the best trim size for your book (usually between 5 x 8 and 6 x 9) 
4. Open Adobe InDesign and create a blank book document at the appropriate size with the best 

margins and bleed settings for your genre 
5. Import the clean and pre-formatted Word file into Adobe InDesign (press “shift” to enable new 

pages to be created to import the entire document) 
6. Create styles for all of the following: 

a. Title 
b. Sub-title 
c. Author name 
d. Praise and testimonials 
e. Praise and testimonials author name 
f. Copyright page 
g. Table of Contents entries 
h. Front and back matter titles/headings 
i. Part or section titles 
j. Chapter titles 
k. Drop caps for first paragraphs 
l. Break symbols 
m. Main body text 
n. Bullet points (separate styles for first, middle, and last points) 
o. Numbered lists (separate styles for first, middle, and last entries) 
p. Quotes 
q. Quote authors 
r. Block quotes (embedded letters, long quotes, etc.) 
s. Call-outs 
t. Images 
u. Footnotes 
v. Endnotes 
w. Appendices 
x. Calls to action 



 

 

y. Running headers 
z. Page numbers 

7. Create the following master pages 
a. Front and back matter pages 
b. Part or section pages 
c. First pages for chapters 
d. Main body text pages 
e. Blank pages 
f. Additional master pages for special designs 

8. Assign all appropriate styles to all text 
9. Create tables and charts within Adobe InDesign 
10. Fix all widows and orphans 
11. Fix ladders 
12. Make sure sub-headings don’t fall at the bottom of a page 
13. Check for kerning and spacing issues 
14. Assign appropriate master pages 
15. Insert the TOC (table of contents) 
16. Double-check that all of the page numbers in the TOC match the page numbers of the chapters and 

other TOC entries in the main body of text 
17. Go through the entire book design, page by page, to look for any corrections missed 
18. Export Adobe PDF for KDP (PDF/X-1a:2001) 
19. Export Adobe PDF for IngramSpark (PDF/X-1a:2001 with 0.125” bleed around the outside) 
20. Go through one of the PDF files (usually the one exported for KDP) to triple-check for errors 
21. Make adjustments, if necessary, in Adobe InDesign and re-export files 

 
 
 

COVER DESIGN 
 
1. Research book category 
2. Research bestselling books in similar category 
3. Search for imagery 
4. Save several image options 
5. Download template for correct trim size (200 pages to start) 
6. Add guides to trim area of front cover 
7. Create folders for each element (front, spine, back) 
8. Begin with text elements for front cover 
9. Place all cover text (title, subtitle, author name, etc.) 
10. Choose font for title 
11. Size title text 



 

 

12. Choose font for subtitle 
13. Size subtitle text 
14. Choose font for author name 
15. Size author name text 
16. Choose fonts that are the same, variations of the same, or complimentary to each other 
17. Place image(s) 
18. Make sure image is moved to bottom layer, below folders 
19. Add any texture or effects to image(s) as needed 
20. Arrange text over imagery 
21. Adjust font colors and effects to compliment imagery 
22. Add glow or shadow as needed to text 
23. Crop around guides for all drafts before sending 
24. Label each file with title and version number 
25. Copy title and author name from front and duplicate in Spine folder 
26. Turn title text 90 degrees clockwise 
27. Place title text in spine area 
28. Reduce title text to fit in spine 
29. Turn author name 90 degrees clockwise 
30. Place author name in spine area 
31. Reduce text to fit in spine, smaller than title 
32. Add any spine logos 
33. Add back cover copy to Back folder 
34. Place back cover copy 
35. Add author image 
36. Place logo(s) at the bottom of back cover 
37. Place barcode at bottom right of back cover 
38. Arrange text to flow around image or 
39. Add box to cover back 
40. Add filter to box to blend with image (if possible, if image flows to back) 
41. Download all necessary templates for final page count, paper color, trim size 
42. Place finalized cover on final templates 
43. Resize spine text as needed to fit within safety zone 
44. Flatten cover 
45. Save as PDF/X-1a:2001 

 

EBOOK DESIGN – PHASE 1: MS WORD FILE FORMATTING 
 
1. copy TOC from print PDF into Word file (if needed) 
2. copy any other front matter that did not export to the Word file 
3. remove all borders (give steps) 



 

 

4. select all (the entire document) 
5. go to Format  > Borders and Shading >  
6. click on box next to None, then click OK 
7. delete a half title page if present 
8. resize fonts and spacing on title page 
9. shortcut to paragraph settings: “command-option-m” 
10. select all text on title page and remove indent 
11. go to paragraph settings (use shortcut or Format > Paragraph) 
12. under Indentation, make sure all three settings are at 0 
13. main title receives H1 style (18-pt font, bold, centered, 0 space before, 18-pt space after, 0 in Special 

(no first line indent), page break before) 
14. subtitle is 16-pt font if short and 14-pt font is long, 36-pt space after, regular, centered 
15. author name is 14-pt font, 0-pt space after, bold, centered 
16. remove page numbers in TOC 
17. make sure all TOC entries are left-aligned with no indentation 
18. give a 6-pt space after most TOC entries 
19. Make sure TOC text matches the PDF 
20. change styles for chapter headings (including Parts, Sections, Foreword, About the Author, 

Acknowledgments, etc.) to H1 style 
21. If there’s a number first and chapter title on second line, then separate these two with shift-enter 

instead of just enter. This keeps them as part of the same paragraph 
22. change styles for first subheading to H2 (16-pt font, bold, left-aligned, 18-pt space before, 12-pt 

space after, 0 in Special (no first line indent)) 
23. change styles for second subheading to H3 (14-pt font, bold, left-aligned, 12-pt space before, 0-pt 

space after, 0 in Special (no first line indent)) 
24. make sure the first paragraph in a chapter or after a subheading or break is not indented if it 

appears that way in the PDF 
25. delete call-outs (unless specifically requested to keep them) 
26. delete tabs and replace with single space 
27. delete double spaces 
28. go to Edit > Find > Replace or type “command-shift-h” 
29. type two spaces in find field (top one), type one space in search field (bottom one), click Replace All 
30. Next, type one space in the find field and one space in the bottom field and click Replace All. This 

removes all wonky spaces. 
31. verify that all images that are in the print PDF are also in the Word file 
32. make images inline instead of floating 
33. double-click on image 
34. click on Layout if that doesn’t menu doesn’t appear near the top 
35. click on Position and choose image under In Line with Text 
36. Delete blank lines for writing in answers.  

 



 

 

EBOOK DESIGN – PHASE 2: JUTOH FILE FORMATTING 
 
1. Open Jutoh and Select “Create New Project” 
2. Add Book title, Author, Date, Publisher, and Publisher Site (URL). Click Next. 

(Only add Publisher and URL if available.) 
3. Under Project Location, click on three dots after Project folder and choose the folder where you want to 

save the Jutoh file. (This should be in the same folder as the Word file and cover image.) Click Next. 
4. Under Layout Choice, leave the setting for Normal reflowable book and click Next. 
5. Under Import Options, make sure that the setting for Resize images to max is at 1120. Make sure the box 

is unchecked for Remove any page breaks. 
6. Click Next. 
7. Under Import Method, click on the second option, From an existing file containing all sections. Choose 

the Word docx file and click Next. 
8. Under Single File Import, choose Split at page breaks (third option). Make sure that the box for Discard 

empty paragraphs is unchecked and click Next. 
9. Under Cover design, choose Use an existing file, click Browse, select the cover file from your project 

folder, and then click FINISH. 
10. assign "toc" guide type to TOC page 
11. right-click on Contents Document on left side of screen and choose Properties 
12. after Guide type, choose “toc” from drop down menu 
13. under Book > Build Table of Contents, make sure that "Leave it to Jutoh" is checked and “Create a 

contents page” is unchecked. 
14. under Book > Document Cleanup, check items in image below and click OK 
15. Under Book > Project Properties, click on Styles and click on Edit Properties at the top of the dialog as 

shown in the image below. Check Use custom CSS and paste in the following CSS code: a:link { color: 
blue; text-decoration: underline; } 

16. Make sure that all TOC entries are linked 
17. select the entire entry 
18. press cmd-shift-g 
19. select the appropriate entry in the box that pops up 
20. press Enter for OK (or click on OK if you prefer clicking)  :) 
21. Make all entries Left-aligned instead of Indeterminate (unless the author wants them centered) 
22. either select all entries and click on Format > Paragraph or edit the style 
23. click on Indents & Spacing 
24. click on Left under Alignment 
25. Make sure that “Chapter” and other titles are added if missing. Sometimes those don’t export from the 

InDesign file, so double-check the PDF every time. 
26. Use Jutoh’s built-in list options for bullets and numbers. Re-apply those list options to the bulleted and 

numbered lists in your file. 
27. select the entire list 
28. unselect the bulleted or numbered list option in Jutoh’s Tools tab in the Palette box in the upper right 
29. all list items should move all the way to the left so there are no indented items 



 

 

30. Select the list items that did not move all the way to the left, and then click on the left arrow above the 
bulleted or numbered list icon until they are all the way to the left. 

31. select all of the list items again and then select the appropriate list option again (bulleted or numbered) 
32. This applies the correct Jutoh option for lists instead of using Word’s version, which doesn’t work well in 

ebooks. 
33. rename side Documents (under Organizer and Projects) 
34. Title page 
35. Copyright 
36. Dedication 
37. if there are extra Documents between chapters because of extra page breaks that were present when 

importing the Word file: 
38. click on the chapter preceding the extra Document 
39. choose Edit > Join Document and click Yes 
40. go through entire document and ensure the formatting in Jutoh matches the formatting in the Word doc 
41. make sure all TOC entries (cmd-shift-G) and hyperlinks (cmd-K) are linked correctly 
42. check configuration for Mobipocket to ensure Paragraph dimension units are set to “Em” 
43. click on Edit after Mobipocket in lower left of screen 
44. enter “dim” in search field at bottom of box that pops up 
45. click on Default (if showing) to right of Paragraph dimension units 
46. select Em 
47. resize images to appropriate width if needed 
48. first compile a Mobipocket version and view images in file using Kindle program 
49. adjust size as following: 
50. click on image 
51. click on Size tab 
52. under Size, make sure Width box is checked and Height is unchecked 
53. choose a percentage and then choose % from the drop-down menu 
54. delete previous version in Kindle program 
55. recompile Mobipocket version and open in Kindle program 
56. double-check image size in Kindle program 
57. Click on current cover image in lower left corner of screen 
58. Click on “Create From Image File” in lower right of box 
59. Click on Browse at bottom 
60. Find cover and click 
61. Click OK 
62. Go through the ebook and add each footnote. Do a search for "1" to find the first one. They should all be 

in superscript. Put your cursor after the number and then press delete to remove it. Leave your cursor 
there and press cmd-shift-n to insert a footnote. Copy and paste the footnote text from the PDF. Click on 
the icon in the upper right that has several short lines with an arrow pointing to the left. Click twice if 
necessary to move the footnote all the way over to the left. If the footnote is a link, select the entire link 
text, press cmd-shift-w and then click OK. 

63. The default setting is for footnotes to go at the end of each chapter. If the author wants all of the 
footnotes to be endnotes that appear at the end of the book, then click on Book > Project Properties > 
Indexes (left side of box) and then Footnotes & Endnotes (top of box). Go to the section below called 



 

 

Endnotes, click on the "Generate endnotes in a separate section", then click “generate endnotes now” 
and click OK. 

64. To add a hyperlink to text within a footnote, select the text, right-click, choose Links > Insert > URL 
65. To remove the heading bullets, go to Book | Project Properties | Fields & Numbering, and clear "Number 

headings automatically". Then use Book | Update to update the headings. 
66. Go to Book | Project Properties | Metadata and see that the Book Title and Author are correct. These 

sometimes are changed to the formatter’s name. 
67. Shorten web links using http://goo.gl 
68. Link using cmd-k, enter 
69. Make sure to add the shortened link where it belongs in the book, not in the endnotes section 
70. When compiling a Smashwords edition, first write “Smashwords Edition” as the last line of the Copyright 

page. 
71. After exporting epub file, go to http://validator.idpf.org and perform an EpubCheck.  
72. If any issues arise on the epub validator, pull up the epub file on the program Sigil. 
73. search “All HTML Files” for the text “value=” (this is the most common error) 
74. Delete all instances (including the space beforehand). 
75. Fix when odd kerning shows up in formatting: If you have styles that are only Current + Properties... and 

don't contain other formatting you want to keep, you can use Find & Replace  
and search for Current + Properties* using additional criteria (type the  
name and asterisk in the field at the bottom of the style selector). In  
the additional criteria Replace field, choose Character Style and select  
(none). Or manually, you can use Format | Text | Reset Text Formatting (Shift +  
Ctrl + R). 

 

 

 

 

 

 

 

 

ARE YOU OVERWHELMED  
BY HOW MUCH THERE IS  



 

 

TO LEARN AND DO? 
 

WHEN WE FIRST STARTED DESIGNING BOOKS,  
IT TOOK US MONTHS JUST TO GET  

ONE BOOK DONE RIGHT. 
 

IF YOU’D LIKE TO BYPASS ALL 351 STEPS,  
SKIP TO THE END OF THE CHECKLIST  

TO LEARN HOW YOU CAN SAVE 10% TODAY.  



 

 

PUBLISHING 
 
ISBN 

1. Create account on Bowker website at myidentifiers.com 
2. Determine your publishing company name (does not have to be a legal company) 
3. Buy ISBNs (one for $125 or ten for $295) 
4. Add title 
5. Add subtitle 
6. Add your book description 
7. Choose your book’s language 
8. Upload front cover 
9. Add author name 
10. Add the author biography 
11. Choose function (author) 
12. Choose the format (ebook, print) 
13. Choose format (electronic book text, paperback, hardback) 
14. Choose first genre 
15. Choose second genre 
16. Choose imprint (you can create new publishing company names to add as an imprint) 
17. Add publication date 
18. Choose title status (active) 
19. Choose target audience 
20. Set price 
21. Choose currency 
22. Choose price type (retail price) 
23. Add ISBN to copyright page of your book (use a different ISBN for each format) 

 
 
 
 

 

 
AMAZON KDP – KINDLE EBOOK 

1. Go to kdp.amazon.com 
2. Create an account and fill in all financial information 
3. Choose Create a New Title: Kindle eBook 
4. Choose language 
5. Add book title 



 

 

6. Add subtitle 
7. Add series title (if applicable) 
8. Add edition number (if applicable) 
9. Add primary author 
10. Add additional contributors (if applicable) 
11. Add book description 
12. Confirm publishing rights 
13. Add keywords (up to seven search terms) 
14. Choose two categories 
15. Add age and range information (if applicable) 
16. Set pre-order (if applicable) 
17. Choose DRM 
18. Upload ebook manuscript (usually mobi) 
19. Upload ebook cover image 
20. Launch Previewer to review ebook 
21. Add ISBN and publisher 
22. Enroll in KDP Select (if wanted) 
23. Choose all territories for distribution 
24. Choose 70% royalty rate 
25. Add price (between $2.99 and $9.99) 
26. Publish ebook 

AMAZON KDP – PAPERBACK 

1. Go to kdp.amazon.com 
2. Choose Create a New Title: Kindle eBook 
3. Choose language 
4. Add book title 
5. Add subtitle 
6. Add series title (if applicable) 
7. Add edition number (if applicable) 
8. Add primary author 
9. Add additional contributors (if applicable) 
10. Add book description 
11. Confirm publishing rights 
12. Add keywords (up to seven search terms) 
13. Choose two categories 
14. Add age and range information (if applicable) 
15. Add ISBN and publisher 
16. Choose publication date 
17. Choose print options 

o Interior and paper type 



 

 

o Trim size 
o Bleed setting 
o Paperback cover finish 

18. Upload paperback manuscript (PDF) 
19. Upload print cover (PDF that includes back, spine, and front) 
20. Launch Previewer to review layout 
21. Choose all territories for distribution 
22. Choose 70% royalty rate 
23. Add price 
24. Choose expanded distribution (if not also publishing via IngramSpark 
25. Publish paperback 

INGRAMSPARK – PRINT BOOK (PAPERBACK OR HARDBACK) 

1. Go to myaccount.ingramspark.com 
2. Create an account and fill in all financial information 
3. Choose add a new title 
4. Select print and ebook 
5. Add title 
6. Add subtitle 
7. Choose language 
8. Add short description 
9. Add keywords 
10. Add series name (if applicable) 
11. Add edition description (if applicable) 
12. Add full description 
13. Add contributors (authors, etc.) 
14. Change imprint if applicable 
15. Add three subjects (categories) 
16. Choose audience 
17. Choose interior color and paper 
18. Choose binding type (perfect bound is typical) 
19. Choose laminate type (for cover) 
20. Add page count 
21. Add print ISBN 
22. Choose pricing 
23. Choose publication date 
24. Choose on-sale date 
25. Upload files 

INGRAMSPARK – EBOOK 

1. Go to myaccount.ingramspark.com 



 

 

2. Create an account and fill in all financial information 
3. Choose add a new title 
4. Select ebook 
5. Add title 
6. Add subtitle 
7. Choose language 
8. Add short description 
9. Add keywords 
10. Add series name (if applicable) 
11. Add edition description (if applicable) 
12. Add full description 
13. Add contributors (authors, etc.) 
14. Change imprint if applicable 
15. Add three subjects (categories) 
16. Choose audience 
17. Add ebook ISBN 
18. Choose pricing 
19. Choose publication date 
20. Choose on-sale date 
21. Upload files 

 
AUTHORCENTRAL 

1. Go to authorcentral.amazon.com 
2. Login with your KDP/Amazon login information (you must have at least one book, print or 

ebook, published on Amazon) 
3. Click on Author Page in main menu 
4. Add author page url 
5. Add biography 
6. Add photos 
7. Add videos 
8. Add link to blog 
9. Click on Books in main menu 
10. Add your book 
11. Add editorial reviews 
12. Add Product (book) Description 
13. Add From the Author information 
14. Add From the Inside Flap information 
15. Add From the Back Cover information 
16. Add About the Author information 



 

 

 
IMAGINE SENDING US YOUR MANUSCRIPT TODAY AND, ONE MONTH 

LATER, YOU’RE HOLDING YOUR BEAUTIFULLY DESIGNED BOOK IN 
YOUR HANDS 

 
100% DONE FOR YOU BY THE JETLAUNCH TEAM. 

 

 

As you can imagine, it’s taken us years to learn how to design a beautiful book that not only will 
you be proud of but will help you build your personal brand, establish yourself as an expert, and 
grow your business. 

We’ve also become so efficient at what we do that we can finish the entire process in less than 
a month. 

We’re so excited to create this experience for you, that we want to give you an incentive to get 
started right away. If you book your 15-minute call within 48 hours of downloading this 
checklist, we’ll give you 10% off! 

 

 

READY TO GET STARTED? 

BOOK your 15-Minute Strategy Call here: 

jetlaunch.link/15 


